Clube do DD-WRT / OpenWRT / Etc.

Discussão em 'Informática' iniciada por _dsouza_, 19 Mar 2017.

  1. Orgun

    Orgun Usuário


    Desde 15 Set 2009
    RS
    Vou tentar explicar aqui.... tenho um Edge Router X com OpenWRT 19, mas não funciona o IPv6.

    Wan é assim:

    Protocol: PPPoE
    Uptime: 0h 6m 59s
    RX: 61.72 MB (49132 Pkts.)
    TX: 3.07 MB (33544 Pkts.)
    IPv4: XXX.XX.X.XX/32
    IPv6: fe80::1a3:f0e7:c511:1853/128

    =================================

    vou em editar na WAN e configurações avançadas e boto:

    Obtain IPv6-Address: Automático.

    Salvo e já aparece WAN_6 com

    Protocol:
    Virtual dynamic interface (DHCPv6 client)

    Protocol: Virtual dynamic interface (DHCPv6 client)
    Uptime: 0h 0m 46s
    IPv6: X:Y:aaa:ba2:1a3:f0e7:c511:1853/64
    IPv6-PD: X:Y:bbb:7ce::/64


    Todos os clientes recebem IPv6, masss nada funciona em IPv6.

    C:\Users\Bruno>ping ipv6.google.com

    Disparando ipv6.l.google.com [2800:3f0:4001:801::200e] com 32 bytes de dados:
    Esgotado o tempo limite do pedido.
    Esgotado o tempo limite do pedido.


    tirei foto do roteador, ping, tracert e teste de IPv6 e mandei para o provedor, eles me disseram que eles usam somente SLAAC.

    E então ai está, se eu tentar criar uma interface Nova só tem opção de:

    DHCPv6 client
    PPPoE
    Static address
    PPP
    Unmanaged
    DHCP cliente

    Não tem SLAAC.... Como c*os eu configuro SLAAC?
     
  2. The Brain

    The Brain Usuário Participativo


    Desde 5 Set 2008
    São Paulo/SP
    O serviço de DDNS da D-Link (powered by Dyn) será encerrado.

    Segue e-mail que recebi hoje:


    Atualmente eu nem estou mais usando, mas agora quando eu precisar vou ter que voltar pro No-IP.
     
    • 2
  3. bruno_rio021

    bruno_rio021 Usuário

    381 130 78

    Desde 23 Out 2011
    Tijuca/Rio de Janeiro/RJ/BR
    Sendo sincero... durou mais que a maioria. Deixava de "backup".... migrei pro duckdns, justamente esperando que acabasse.
     
    • 3
  4. The Brain

    The Brain Usuário Participativo


    Desde 5 Set 2008
    São Paulo/SP
    Eu não conhecia esse.

    Legal que ele tem um DynDNS endpoint, o que o torna compatível com praticamente todos os roteadores, inclusive os de operadoras.

    Parece o substituto ideal pro dlinkddns.
     
  5. placard

    placard Usuário

    8.142 4.646 931

    Desde 29 Mai 2008
    SBJP
    Também uso o duckdns há mais de 1 ano para dar acesso ao meu site que hospedo em casa mesmo.

    Bom falar nisso, estou retornando ao tópico depois de um breve período com o pfSense, que não chegou aos pés do OpenWrt na minha opinião. Muito inferior.

    Mas com uma diferença... estou usando num computador x86_64, e não mais em roteadores SoHo típicos.
    :D:feliz:

    No momento, com wan dual stack IPv4/6 obviamente, e 2 internas, uma pra aparelhos domésticos outra pra câmeras de vigilância (segregadas em subnet e totalmente restritas via firewall), sendo que a Lan ainda se subdivide em uma vlan para wi-fi de visitas (via 802.1q configurado para dar suporte a um ponto de acesso Unifi com 2 redes sem fio).

    Na lan principal, IPv6 stateless obtido via delegação de prefixo, sem dhcpv6.

    Depois posto mais dessa odisseia que foi ir para o pfSense e voltar.

    [']s!
     
    • 3
  6. bruno_rio021

    bruno_rio021 Usuário

    381 130 78

    Desde 23 Out 2011
    Tijuca/Rio de Janeiro/RJ/BR
    Aguardando isso ai... estou querendo dar uma reduzida no meu looping infinito aqui.
    Minha "borda" hj é:
    -MK (RB760igs)
    -pfSense (Zotac Zbox CI323)
    -cloud key gen2
     
    • 1
  7. placard

    placard Usuário

    8.142 4.646 931

    Desde 29 Mai 2008
    SBJP
    Então… eu tinha um TP-Link 1043nd, v1.1 eu acho, no qual usava OpenWrt. Isso pode ser visto na primeira página deste tópico. Recentemente, a rede se tornou mais complexa, com 3 subnets etc. etc. A história abaixo é curiosa e posso dar maiores detalhes sobre cada item pra quem se interessar.

    Por isso, adquiri um mini PC x86_64, com i3-4005U, 4GB e 60GB de SSD para usar como roteador (é, eu sei, hehe…). Inicialmente, pensei em usar pfSense, simplesmente porque a dupla pfSense + Unifi AP (uso um UAP-AC-LR) é muito comum e há muita informação sobre os dois juntos. De fato, configurei tudo em acho que 1 hora (fora download e instalações de sistemas, obviamente) sem nunca ter usado os dois.

    Tudo bem até a quarentena, pois nela a Claro/Net piorou muito o serviço, com muita instabilidade. Por algum motivo, quando a WAN caía, o stack IPv6 ficava louco. Apareciam vários logs de erro do dhcp6c (cliente DHCP v6) e do radvd (programa residente de anúncio de roteador em uma rede v6), que não conseguiam acompanhar, por tudo que li na Internet, as mudanças de endereços e rotas, problema amplificado e acelerado pelas constantes quedas na rede. O software bugava e eu passava a ter pings de 5, 10 segundos pra qualquer coisa que passasse pelo roteador (i.e., até um ping para o próprio), mantendo média de 20% de perda de pacotes ao longo das horas. A única coisa que resolvia era resetar.

    Isso tudo é uma simplificação, pois passei semanas me chateando com essas coisas no pfSense. A gota d'água foi eu ver vários problemas idênticos ao meu, mesmo setup (ipv6 na LAN com track interface e IPv6 na WAN com DHCPv6 etc.) no fórum e o suporte do pfSense dizendo que a culpa não é do sistema e sim da conexão, como se isso fosse desculpa pro sistema enlouquecer e não se autocorrigir quanto a rotas, endereços etc., quando o próprio pfSense é excelente para diagnosticar problemas (gráficos, média pacotes/tempo, gateway, interfaces, serviços, tudo tem vários logs e estatísticas).

    Além de não inspirar confiança pelo suporte, que mais parecia interessado em defender o produto do que encontrar falhas, fiquei com a sensação do sistema ser uma quimera monolítica instável.

    Dito isso, deixei de lado o pfSense e, aproveitando que teria que voltar ao OpenWrt, que eu já conhecia, fui atrás de experimentar com um roteador homebrew/caseiro. Instalei o Ubuntu server e daí fui configurando e adicionando as partes necessárias. Gastei quase 2 dias com isso, e foi bastante proveitoso para aprender sobre alguns detalhes de rede... configurei manualmente a rede, os clientes DHCP, fiz minhas próprias regras iptables manualmente (achei que seria até mais difícil do que foi), mas não consegui fazer funcionar IPv6 na rede interna porque não há um cliente que, ao receber e atribuir um novo IPv6 na WAN, atribuísse um endereço IPv6 à interface da LAN seguindo o esquema ditado pelo prefixo delegado que recebo do provedor (no caso, a Claro/Net).

    Então a solução seria o cliente DHCP que escuta na WAN ter um hook de evento de ifup na WAN que expusesse o prefixo delegado, e aí esse hook chamaria ou o próprio cliente para atribuir também um ipv6 na interface LAN (mas não qualquer IP, mas sim um de acordo com o prefixo delegado), ou um outro cliente DHCP, e não só isso, mas teria também que organizar a desativação e ativação do servidor DHCPv6/radvd/etc. na LAN, para que os clientes passassem a receber IPv6 na nova faixa. Caso minha faixa de IPv6 na Net fosse fixa, eu não teria tido problemas. Mas como é dinâmico, não consegui resolver. Estava perdendo tempo demais para um hobby, pra eu mesmo fazer os scripts dessa bagunça toda. Eu teria que misturar clientes DHCP (WIDE DHCP vs ISC DHCP)… tudo com scripts, meio bagunça e propenso a falhas. Também não consegui desvendar os segredos do SystemD para substituir peças (substituir isc-dhcpc pelo wide-dhcpc, por exemplo).

    De qualquer forma, dois comentários: com apenas IPv4, o roteador Linux do zero que fiz funcionou perfeitamente. Dava IPs, firewall apropriado (totalmente trancado, exceto para o que queria), respondia a DNS, NTP, NAT, acesso a Internet, DHCP, DHCP estático, tudo. Inclusive era visivelmente mais rápido que o pfSense. Dava pra ver apenas acessando a Internet nos clientes. Mas IPv6 com PD não. Segundo comentário é que, apesar de ser um sistema com pilha de software extremamente segura e quase diariamente atualizada, eu não sou expert em segurança, então não confio em mim mesmo para criar um stack de roteador. Melhor deixar para os profissionais. Não recomendo isso para algo que não seja experimentação.

    Depois dessa aventura que me permitiu conhecer mais de redes em Linux, voltei para o OpenWrt. Vou relatar numa nova mensagem com as configs e tudo mais.

    [']s!
     
    • 3
    • 1
  8. W49n3r

    W49n3r Usuário


    Desde 18 Mar 2015
    Campinas SP
    Claro que cada um tem sua experiencia e sua opinião, mas classificar o pfSense como instável é no mínimo leviano. A minha experiencia é que a confiabilidade e estabilidade é altissima: tenho vários em ambientes produtivos com centenas de usuários e meses de uptime. A maturidade e comunidade que o usa ativamente é tal que dá para dispensar o suporte oficial tranquilamente. Nunca usei...

    Para outros que estejam considerando o pfSense... sim, é bom e é confiavel. Existem soluções melhores? Claro que existem... mas a proposta do pfSense é honestissima.
     
  9. placard

    placard Usuário

    8.142 4.646 931

    Desde 29 Mai 2008
    SBJP
    Bem, voltando ao OpenWrt. Esta mensagem vai ser mais um HowTo do que um “diário”, hehe. Igualmente, para detalhes é só perguntar.

    1. Modem: Claro/Net Thomson DWG874, firmware STBC.52.21 (maio de 2015).

    Tudo desativado, até WiFi. Funciona apenas como bridge para o roteador receber os IPs via DHCP v4+v6.

    2. AP WiFi: Unifi U AP-AC-LR.

    Vantagens: usa um único SSID para 2,4 e 5Ghz simultâneos, simplificando para os clientes. Excelente alcance, excelente velocidade. Permite mais de uma rede simultânea dual 2+5 (acho que até 4 redes, não lembro). Permite controle de banda para cada SSID. Configuração ridiculamente fácil.

    Desvantagem: não há interface de config do aparelho. Você instalar um servidor web no seu computador, e abre a página de config no seu computador. E por debaixo dos panos essa página se comunica com o AP configurando. Fora isso, não funciona bem no Linux, mas dentro de uma VM Windows funcionou perfeitamente. E você pode desinstalar depois.

    Criei 2 redes, com seus SSIDs: uma <nome>, outra <nome>-guest. No AP, configurei <nome>-guest para usar a vlan tag de 10, e limitei a banda total para 2 mbps down e 512 kbps up no próprio AP. A principal foi configurada para a faixa 172.22.0.0/24, e, a segunda, 172.22.1.0/24.

    Há muitas configurações, funções etc., mas pra mim bastou isso. Explico a tag vlan adiante.

    3. Roteador: Qotom mini PC i3-4005U, 4 GB de RAM e 60 GB SSD.

    Excelente, mais do que o necessário :D. A maior utilidade aqui são, além da serial padrão (conector DE-9), as 4 portas de rede independentes (não há switches):
    Código:
    root@nemo:/sys/class/net# ll
    drwxr-xr-x    2 root     root        0 May 26 02:59 ./
    drwxr-xr-x   48 root     root        0 May 26 02:59 ../
    lrwxrwxrwx    1 root     root        0 May 26 02:59 eth0 -> ../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/net/eth0/
    lrwxrwxrwx    1 root     root        0 May 26 02:59 eth1 -> ../../devices/pci0000:00/0000:00:1c.1/0000:02:00.0/net/eth1/
    lrwxrwxrwx    1 root     root        0 May 26 02:59 eth1.10 -> ../../devices/virtual/net/eth1.10/
    lrwxrwxrwx    1 root     root        0 May 26 02:59 eth2 -> ../../devices/pci0000:00/0000:00:1c.2/0000:03:00.0/net/eth2/
    lrwxrwxrwx    1 root     root        0 May 26 02:59 eth3 -> ../../devices/pci0000:00/0000:00:1c.4/0000:04:00.0/net/eth3/
    lrwxrwxrwx    1 root     root        0 May 26 02:59 lo -> ../../devices/virtual/net/lo/
    Esqueça o eth1.10 por enquanto. Explico a seguir.

    Para instalação, usei a 19.07.3 (x86_64) openwrt-19.07.3-x86-64-combined-ext4.img . Não usei o sistema de arquivos squashfs porque tenho um SSD de 60 GB, então é do meu interesse usar tudo isso. Redimensionei a partição 2 que vem na imagem para ocupar todo o disco. Provavelmente nunca vou usar nem 5% disso.

    Tirei o HD do computador, coloquei no roteador. Liguei o roteador, sistema iniciou e, com o teclado e uma TV, fiz opkg update e opkg upgrade. Atualizou alguns pacotes, principalmente a interface de configuração http (luci).

    Em seguida, usei o comando cat /etc/config/network, e vi que a lan estava na interface eth0 com IP fixo 192.168.1.1/24, como é o padrão do OpenWrt. Pode ser confirmado também com ip a. Nesse momento usei o comando poweroff, tirei TV, teclado, instalei o roteador no seu lugar definitivo e passei a gerenciar apenas por computador por http://192.168.1.1.

    Configuração:

    Sistema: 512 KB de buffer de logs, sem servidor de log. Ativei NTP Client e Provide NTP server, e desativei Use DHCP Advertised Servers. Escolhi os servidores manualmente:gps.ntp.br, a.ntp.br, b.ntp.br, time.nist.gov, time3.google.com. Pode adicionar quantos quiser, mas não sei como o cliente NTP do OpenWrt os utiliza, se faz alguma comparação entre ambos etc.

    Administração: SSH Access, apenas na LAN, porta 22, permitir autenticação por senha, permitir senha do root, e desativei Gateway ports porque não quero permitir acesso SSH via Internet. Importei minha própria chave publica para usar com SSH na outra subguia, mas não seria necessário para uso normal.

    Interfaces: não consegui criar a vlan. Dizem que é muito fácil, mas como já conhecia o arquivo /etc/config/network, preferi fazer manualmente via SSH:
    Código:
    root@nemo:/etc/config# cat network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fddd::/48'
    
    config interface 'lan'
            option ifname 'eth1'
            option proto 'static'
            option netmask '255.255.255.0'
            option broadcast '172.22.0.255'
            option ipaddr '172.22.0.254'
            list dns '172.22.0.254'
            option ip6assign '64'
    
    config interface 'guest'
            option ifname 'eth1.10'
            option proto 'static'
            option netmask '255.255.255.0'
            option broadcast '172.22.1.255'
            option ipaddr '172.22.1.254'
            list dns '172.22.1.254'
            option delegate '0'
    
    config interface 'cam'
            option ifname 'eth2'
            option proto 'static'
            option netmask '255.255.255.0'
            option broadcast '172.22.2.255'
            option ipaddr '172.22.2.254'
            list dns '172.22.2.254'
            option delegate '0'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
            list dns '8.8.4.4'
            list dns '208.67.220.220'
            list dns '8.8.8.8'
            list dns '208.67.222.222'
            option peerdns '0'
    
    config interface 'wan6'
            option ifname 'eth0'
            option proto 'dhcpv6'
            list dns '2001:4860:4860::8888'
            list dns '2620:119:35::35'
            list dns '2001:4860:4860::8844'
            list dns '2620:119:53::53'
            option reqprefix 'auto'
            option reqaddress 'try'
            option peerdns '0'
    Fiz isso porque achei mais rápido e fácil. Tentei criar a vlan com tag 10 para separar a rede wifi normal da rede wifi de visitas na interface http, mas não consegui. Quando soube que era só criar uma nova interface no arquivo de configuração com o nome "eth1.10" (seção "config interface guest" acima), que o OpenWrt criava sozinho, maravilha. Aproveitei e reboot e apareceu tudo bonito na interface http.

    A partir daí criei a outra interface, cam, na outra porta do roteador. Desativei DHCP nela.

    Código:
    root@nemo:/etc/config# cat dhcp
    
    config dnsmasq
            option domainneeded '1'
            option localise_queries '1'
            option rebind_protection '1'
            option rebind_localhost '1'
            option expandhosts '1'
            option authoritative '1'
            option readethers '1'
            option leasefile '/tmp/dhcp.leases'
            option resolvfile '/tmp/resolv.conf.auto'
            option localservice '1'
            option domain 'enseada'
            option local '/enseada/'
            option quietdhcp '1'
    
    config dhcp 'lan'
            option interface 'lan'
            option ra 'server'
            option start '150'
            option limit '50'
            option leasetime '4h'
    
    config dhcp 'wan'
            option interface 'wan'
            option ignore '1'
    
    config odhcpd 'odhcpd'
            option maindhcp '0'
            option leasefile '/tmp/hosts/odhcpd'
            option leasetrigger '/usr/sbin/odhcpd-update'
            option loglevel '4'
    
    config dhcp 'guest'
            option interface 'guest'
            option start '150'
            option limit '50'
            option leasetime '15m'
    Isso é o que importa. Embaixo disso tem um monte de host de DHCP estático.

    Instalei o pacote luci-ssl para acessar a interface por HTTPS, e ddns-scripts para ddns.

    É isso. Parece mais complicado falando tanto assim, mas foi bastante rápida a configuração. Uns 15 minutos. Qualquer dúvida só perguntar.

    [']s!
     
    Última edição: 28 Mai 2020
    • 2
  10. placard

    placard Usuário

    8.142 4.646 931

    Desde 29 Mai 2008
    SBJP
    Como você pode ver, citei apenas o que interessa. Sua opinião sobre o caráter pessoal do que eu falei é pouco útil pra os outros. Mas, do ponto de vista pessoal, agradeço sua crítica.

    Voltando… falei essa frase citada num contexto de 802 palavras. Claro que o pfSense é confiável, no geral. Ele serve quase todos bem, e a maioria certamente excelentemente bem. No entanto, como os fatos pareceram mostrar, não me serve. E se olhar no Google, não estou sozinho.

    Detesto sequer ter que dizer isso, pois fica parecendo que estamos numa evangelização, e se tem algo que odeio é evangelização, ainda mais de tecnologia. Enfim, cada um que decida se o pfSense é bom ou não pra tal e qual pessoa.

    Por isso mesmo, vou tentar ser mais objetivo, já que estou sendo instigado a isso: não me parece condizente que um roteador atribua um endereço IPv6 antigo à LAN, quando a WAN capturou endereço novo, após período de instabilidade. E pior, sem atualizar as rotas. Eu vejo o log e o que se vê é, ilustrando de forma dramática, o dhcp6c e o radvd “cruzando os braços” e jogando tudo pro ar por algo que só posso concluir como sendo o sistema tentando se recuperar de uma condição imprevista.

    O que pude perceber buscando nos fóruns do pfSense foi um número razoável de incidentes muito similares ao meu, de pessoas com comportamento errático do roteador em IPv6 em conexões instáveis, inclusive com as mesmas mensagens de erro do dhcp6c+radvd. E mesmos sintomas: IP LAN v6 errado, rotas quebradas, lag altíssimo, e resolvendo com reboot.

    Também não gostei de ver o pessoal de suporte nos fórums (gratuitos, verdade!) fazendo a relação causal de que o problema não estava no pfSense porque a conexão era instável. Em outro as soluções apontadas foram "arranjar outro ISP" e comentários de que "não sei o que faria com uma conexão com menos de 99,99% de disponibilidade". Mas vi o mesmo comportamento na lista de bugs: pessoas laudando o pfSense sem endereçar os problemas citados, que deveria ser a função de uma lista de bugs. Fanboísmo puro e simples, pessoas se preocupando mais em defender a imagem (?!?) do pfSense do que em endereçar os problemas trazidos pelos usuários. (y)

    Claro que isso foi uma pequena faceta do pfSense e da comunidade, mas talvez seja isso: o pfSense não é pra mim, e vivemos num mundo com alternativas tanto gratuitas como comerciais. Para outras pessoas ele com certeza funciona muito bem. Viva a diversidade!

    [']s!
     
    • 2
  11. W49n3r

    W49n3r Usuário


    Desde 18 Mar 2015
    Campinas SP
    Curiosamente é muito comum exatamente na área da tecnologia. Normalmente as pessoas defendem o que conhecem mais, o que tem mais experiencia e o que funciona pra eles. E para alguns, não basta apenas esolher a melhor solução... escolhido seu "time" o próximo passo é dizer que o resto é lixo.

    O problema que relatou pode ser muito bem um bug, e provavelmente é contornável por scripts. É uma pena que o suporte official tenha sido tão inutil.
     
  12. bruno_rio021

    bruno_rio021 Usuário

    381 130 78

    Desde 23 Out 2011
    Tijuca/Rio de Janeiro/RJ/BR
    Os meus 2 dedos de contribuição sobre esse "problema" do PfSense em IPV6, sendo bem realista, grandes empresas/corporações não se preocuparam com a migração para o ipv6 (ao menos não ainda) e os "vendors", sejam eles quaisquer que sejam Palo Alto, F5, Check Point e outros N que eu vejo por ai e que poderia citar, se preocupam ainda em entregar TUDO em IPV4 atrás de suas "caixinhas", nas redes 10.0.0.0 com as redes de filiais 172.0.0.0 para outras coisas e em links internacionais 192.168.0.0 da vida... acho que 99% das empresas que passei a receita de bolo não muda e varia pouca coisa.

    Acho que a solução com IPV6 estável e totalmente funcional, virá com a maturidade e crescimento do uso do protocolo. Tem pouco tempo que acompanhei uma migração de link's e ainda há de praxe a venda de blocos ipv4, no contrato e na entrega não vi nada de ipv6 (o fornecedor foi a Claro/NET).

    Ps. Enquanto isso não ocorre, nós que tempos algo "diferente do comum" ou que queremos utilizar o melhor dos dois mundos, sofremos o primeiro impacto e obtemos respostas como essa da equipe da mantenedora do PfSense.
     
    • 1
  13. JP!

    JP! Curioso


    Desde 19 Abr 2008
    São Paulo
    Pessoal, não conheço muito de redes e absolutamente nada de Linux, mas gostaria de usar Pi-Hole para bloquear ads/scripts em casa: https://pi-hole.net/

    Existe alguma VM ou forma de usar isso no W10 aqui, já que o Pi-Hole é para Linux?

    JP
     
    Última edição: 28 Mai 2020
  14. _dsouza_

    _dsouza_ Lost in time

    9.717 3.597 811

    Desde 4 Set 2008
    Porto Alegre
    Usei o DD-WRT por muito tempo, depois usei um ASUS que estragou, e hoje estou contente com o roteador da Synology. Muito completo, tem (quase) tudo o que eu preciso no firmware de fábrica e não preciso perder tempo em buscar uma solução customizada (obviamente perco a chance de aprender com as soluções customizadas).

    Cheguei uma época a olhar o pfSense, mas aí o espaço que tenho para o roteador princiapl é pequeno e teria que comprar um x86 miniatura, e a brincadeira ficaria cara.

    Uma coisa que sinto falta: VLAN tagging para multiplos pontos wifi. Tenho um rotador principal e mais 3 roteadores operando com pontos de acesso. Até consigo configurar uma rede Wifi "guest" no roteador principal, mas nos outros não adianta. O certo seria ter uma VLAN separada só para a rede guest, e que cada ponto de acesso permitisse uma rede wifi guest que fosse associada à essa VLAN.

    Achei apenas os roteadores e pontos de acesso da Ubiquity permitem de maneira simples associar redes wifi/SSIDs específicos com uma VLAN específica, mas os preços são abusivos... E ainda assim não sei se serviria ao meu propósito (precisaria de 2 redes wifi em cada ponto de acesso, cada uma com um SSID próprio associada à uma VLAN específica, e o roteador principal com um DHCP separado para cada VLAN)...
     
    • 1
  15. bruno_rio021

    bruno_rio021 Usuário

    381 130 78

    Desde 23 Out 2011
    Tijuca/Rio de Janeiro/RJ/BR
    @placard@placard
    Esqueci de agradecer pela explanação! Vou seguir essas orientações e fazer uns testes...

    Ter, tem... se é estável, eu não sei. Vc pode instalar em docker (exemplo), mas ainda assim eu te recomendaria ter um raspberry nesse caso (até pelo consumo) e tbm pq se vc desligar a sua máquina a sua rede para já que ele passará a ser o seu DNS e assim você não resolveria um simples google.com ou o próprio site do HT.

    Pelo que entregam... eu nem acho abusivos os preços, pq o foco deles é corporate e basta ver os preços de concorrentes como o Cisco Meraki. A maioria das pessoas que acabam pegando eles pra uso residencial, como é o meu caso e acho que do Placard tbm... é justamente pelas "facilidades" e pra resolver "problemas", mantendo um controle bem legal e quem foge dessa linha, dessa necessidade, acaba indo pros "mesh".
    Eu tenho em casa uma penca de equipamentos, pra lab, uso e estudo e acho que tirando o mikrotik nenhum deles é 0, eu fico garimpando o ML, fóruns e grupos. Meus ap's por exemplo foram "baratos", foram 3 AC LR a 400 cada, mas esteticamente detonados. Parece que os caras fizeram obra e não tiraram os ap's, cheios de respingos de cimento, de tinta.... levei uns 4 meses pra achar carcaças "novas" pra todos - não consegui em lugar nenhum peças de reposição, mais uma vez os usados me salvaram. Gastei no total quase 1.6k neles e troquei um notebook que estava parado aqui na controladora pouco antes do inicio da quarentena (está em produção aqui em casa, mas vai pra casa dos meus pais no interior de minas).

    Ps. Se algo não tiver mudado desde a última vez que eu parei pra ler o datasheet, se eu não me engano são 3 ou 4 SSID nos AP's "N" e 6 ou 8 nos AP's "AC" com vlans apartadas. Eu em casa tenho esse cenário, com vlans e redes apartadas: interna 172.*.*.* e guest 192.*.*.*!

    O que eu queria mesmo é me contentar com o que tenho, diminuir os "projetos DIY" e parar de trocar meus equipamentos a cada 6 meses e me estabilizar com uma solução... :D
     
    • 3
  16. placard

    placard Usuário

    8.142 4.646 931

    Desde 29 Mai 2008
    SBJP
    @_dsouza_@_dsouza_

    Infelizmente não tenho como testar porque só tenho 1 ponto da Unifi. Mas acho que funcionaria, pois lembro que o controlador dos Unifi gerencia todos os pontos em conjunto, como se fossem um só, me permitia tratar todos como um. É em outro local que se adiciona ou remove pontos Unifi desse "set". Mas não vi sobre isso, não me interessei em múltiplos APs. E tenho certeza que você já contemplou todas essas opções.

    Outra coisa que eu lembraria é que comprei o LR (long range) justamente por isso: antes da instalação, medi de forma bem amadora, "nas coxas", a recepção e o nível de ruído e redes com interferência em cada local onde eu queria usar o wi-fi. Com isso fiz um mapa com a planta do imóvel, e instalei no teto e no local mais equidistante deduzindo a proximidade com os locais com menor sinal, e evitando ao máximo o nº de paredes em todas as direções onde ficaram os principais clientes (priorizei os fixos).

    Se teve uma coisa que, na minha humilde opinião, valeu a pena, foi comprar esse ponto de acesso Unifi. Tudo bem que o posicionamento ficou melhorado, mas ainda assim é muito bom, e consegui cobrir bem todo o imóvel mesmo sem ser na potência máxima. Os roteadores Unifi eu dispensei porque olhei muito rapidamente e, além de caros, me pareceram menos transparentes do que um x86 mini PC com pfSense. Embora repito, tenha olhado quase nada, foi só impressão, até porque o preço me fez desistir.

    E sim, como Bruno falou acima, meu uso é residencial, para resolver os problemas e, principalmente, limitações que vi em opções mais módicas.
     
    • 1
  17. bruno_rio021

    bruno_rio021 Usuário

    381 130 78

    Desde 23 Out 2011
    Tijuca/Rio de Janeiro/RJ/BR
    • 2
  18. placard

    placard Usuário

    8.142 4.646 931

    Desde 29 Mai 2008
    SBJP
    Ah, muito bom. Pelo que vi aí nas configurações, é do jeito que imaginei mesmo com múltiplos APs, o que bate com os locais que conheço usando vários e vários APs Unifi.

    Só mostrando... preferi limitar a banda de guest porque achei mais prático no AP que configurar no roteador. Lá nas configurações você cria um user group, definindo os limites de banda, e depois nas wireless networks define o user group pra ela.

    É só isso que é necessário. É realmente muito bom.

    Claro, no meu caso tinha mais de uma rede então precisei definir duas redes sem fio e uma delas com a tag 10 (pra usar eth1.10 no roteador), mas aí é mais fácil ainda: só digitar "10" no campo vlan tag.

    Muito, muito prático. E funciona.sem.instabilidades.
     
    • 2
  19. bruno_rio021

    bruno_rio021 Usuário

    381 130 78

    Desde 23 Out 2011
    Tijuca/Rio de Janeiro/RJ/BR
    Sobre o DDNS da D-Link, por um acaso entrei na página da DynDNS que era o provedor do serviço que eles entregavam... a empresa foi comprada pela Oracle, até aquele simbolo preto e amarelo deles deixou de existir.
    Talvez tenha sido esse o motivo para o encerramento da parceria.

    Ps. Não sei quando essa aquisição ocorreu, uso o duckdns a uns 5 ou 6 anos já. Tanto que o meu login ainda é usuário e senha, que nos dias de hj, não é mais permitido.
     
    • 2
  20. The Brain

    The Brain Usuário Participativo


    Desde 5 Set 2008
    São Paulo/SP
    • 1
  1. Usamos cookies próprios e de terceiros para dar um melhor serviço e mostrar publicidade. Ao continuar, aceita o seu uso.
    Fechar Aviso